File Upload Error every time

I’m testing out the SparkLite service. I’ve created a really simple test sheet, and I’ve downloaded a few of the sample sheets provided.

I’ve created things correctly with a simple Xinput and Xoutput.

No matter what I try, I always get a “File Upload Error” on any file I try to push up. This includes trying to upload one of the sample sheets that they provide to download.

I’m using the current version of Chrome BTW and working with Excel in MS 365 (version 2210)

Is the uploader just offline at the moment or is there something wrong with my setup?

Thanks,
Dan

Hi Dan,

Thanks for trying out SparkLite and sorry to hear you are having issues with the upload.
I have just tried to upload a sample file and didn’t see any issues in the process. Could you try uploading again?

If you continue to have issues, please feel free to get in touch via hello@sparklite.io and the team can take a more detailed look in to your issue.

We will also take a look in to the logs today to see what’s going wrong with your account and post back here with what we find.

Cheers

Daniel

I’m having the same problem. Tried twice today 12-6-22 and getting an error saying try again later Maybe I’ll try on another browser.

The same thing happens even when I use their templates.

Hi there! Welcome to our community. Sorry to hear you are having trouble with the upload!

Can I get more details for troubleshooting?

  • Which template did you try to upload?
  • Can you pinpoint the approximate time you tried to upload?
  • Are you facing the same issue with all kinds of spreadsheets?

Thanks,
Sadhana

not the original commenter but i’m also now getting a file upload error each time, whereas it had been (barely) working previously. i say barely due to the token timeout issue.

1 Like

Hey @bennymac1 :wave:t4: we did identify one of the scenarios where when soon someone logs in, they get to see a NOT_FOUND toast in the top-mid section of the screen and subsequent attempts to upload any file fails as well.

Are you too experiencing something similar? If so, a fix is already underway and we expect that to be resolved by this week :crossed_fingers:t4:
If not, it would help to debug your specific scenario a bit deeper too.

We’re also working on fixing the token timeout issue as well (hoping to have this resolved before Christmas) - can totally understand how challenging it could be to work with until then :sweat_smile:

Best,
Sourabh

Hi Sourabh, I’m not seeing ‘NOT_FOUND’ message. I do see a new popup that indicates that the tokens change every two hours though… Sparklite is unusable for me at this point.

1 Like

Can totally understand that, @bennymac1 - we are working on a long-term permanent fix for the expiring tokens so figured in the interim, might help users to even just know about what they’d need to do at the very beginning.
It’s fair in case you’d wish to pause your usage until we have that sorted.

On the other issue of the error you’re getting to see while uploading your file, if you’re up for it, please do send us the file that you’re trying to upload (if possible & in case it’s not confidential) on hello@sparklite.io along with a screenshot of the error you’re getting to see, preferably with a video walkthrough with your browser’s network tab open (you may also be able to see the errors on the browser console).
Alternately, I’d be happy to jump on a quick call with you too so we could go over this together on a screenshare.

Truly regret all the hassle and inconvenience on this but please be assured that our teams are actively working on having these addressed ASAP!

Best,
Sourabh

Hi Sourabh, thanks for getting back to me. Can I ask that my fees get refunded until the issues are sorted? I’m still using the same file that I shared with you on our video call, so I dont think the file upload issue is on my end. Something must have changed on sparklite’s side to cause the file upload error.

1 Like

Thanks for confirming, @bennymac1 :raised_hands:t4:

Ran into an upload error when I tried doing so with the same excel file that you’d shared on our earlier call and looks like that’s happening because of the function in cell P2 (=TTEST()) which shows-up under “Compatibility Functions” on my version of MS Excel.
Nonetheless, changing it to =T.TEST() (adding a period after the first T) as shown in the official docs, saving and re-uploading that sheet fixes the issue & the API is created successfully :blush:

I’ve also reached out to our team on the refund - will make sure to keep you posted on the process for that.

In the meantime, be great to get your input on whether the aforementioned tweak solves at least a part of the problem for you :sweat_smile: (expiring bearer token scenario will take a bit more time to resolve).

Best,
Sourabh

Hey @DanUnderhill, @tmmerlo, @bennymac1 :wave: we have fixed both issues — the file upload and the expiring tokens — from our end (documentation for this will be updated too).

Please do to test them out and let us know in case you still run into the same issue as before.

@bennymac1 — my colleague (Jason) must’ve already reached out to you too on the credits :blush:

Best,
Sourabh